MB, MBR and MBAC Bug Report Thread

Let's talk about the port of the port of the port of the update of the port of the port of the update of the expansion of the game that will apparently never be awesome enough.

Moderator: Staffers

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » October 11th, 2011, 3:44 pm

That could be related the OP movie. Please try installing the game with/without subbed movie, and see if it makes a difference.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby helloworld13 » October 12th, 2011, 3:19 am

I tried with the movie subbed and unsubbed. Both crashed the game. I did try playing the unpatched game with the subbed movie (I just replaced the MBOP.mpg file) and it seemed to work, so I don't think it's a problem with the movie. I'm pretty sure the patch applied correctly since I have no problem playing it on XP (I dragged the same whole install folder to another computer of mine to test the game). This is the crash result I get on 7:

Problem signature:
Problem Event Name: APPCRASH
Application Name: mb.exe
Application Version: 0.0.0.0
Application Timestamp: 3ef2bf6b
Fault Module Name: StackHash_2ff1
Fault Module Version: 6.1.7601.17514
Fault Module Timestamp: 4ce7ba58
Exception Code: c0000374
Exception Offset: 000ce653
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 2ff1
Additional Information 2: 2ff1112d70d72cfc6891ac4a563a154a
Additional Information 3: 3931
Additional Information 4: 3931c229ff114383a03e72af406d97b7
helloworld13
Totally hardly posted
 
Posts: 3
Joined: October 10th, 2011, 12:44 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby helloworld13 » October 21st, 2011, 12:13 am

So I'm guessing there's no solution for this?
helloworld13
Totally hardly posted
 
Posts: 3
Joined: October 10th, 2011, 12:44 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » October 22nd, 2011, 6:12 am

I'm busy moving, so response is slow. Also, I don't have much of an idea at this moment. I suggest you drop by in the IRC channel and see if you can poke another staff member.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby anticitizen_one » May 28th, 2012, 4:07 pm

I'm having the same issue helloworld13 was having with original Melty Blood crashing in Windows 7 after the OP video. However, I would like to point out that it doesn't crash until after the video is over and if you just skip it, the game runs fine, so it's not a gamebreaking issue so much as an annoyance.
anticitizen_one
Totally hardly posted
 
Posts: 4
Joined: May 28th, 2012, 4:04 pm

Re: MB, MBR and MBAC Bug Report Thread

Unread postby ArchDemon » May 29th, 2012, 3:57 am

Hmm, I'm not sure what's causing the problem.
If you have ffdshow installed, try adding the executable to the blacklists.
If using Win7/Vista, maybe installing it to another folder such as C:\Games\Melty Blood English will help.
User avatar
ArchDemon
Executive Director
 
Posts: 344
Joined: August 18th, 2006, 7:47 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby anticitizen_one » May 29th, 2012, 2:33 pm

Unfortunately neither of those things seemed to have worked.

I do have one more issue though. Does Act Cadenza's OP video need any specific codecs like vanilla Melty Blood does? Because all I'm getting for it is the audio and a black screen. For reference, I'm using CCCP.

Thanks for all the help.
anticitizen_one
Totally hardly posted
 
Posts: 4
Joined: May 28th, 2012, 4:04 pm

Re: MB, MBR and MBAC Bug Report Thread

Unread postby ArchDemon » May 29th, 2012, 3:31 pm

anticitizen_one wrote:Unfortunately neither of those things seemed to have worked.

I do have one more issue though. Does Act Cadenza's OP video need any specific codecs like vanilla Melty Blood does? Because all I'm getting for it is the audio and a black screen. For reference, I'm using CCCP.

Thanks for all the help.

The Japanese OP videos for the MB and MBAC use MPEG-1 video, while the subtitled OP video for MB uses XviD.
The black screen problem is usually caused by an installed codec/playback filter overriding the ones that come with Windows which causes some incompatibility during playback.
The only real solutions I can think of for these problems are to either uninstall the conflicting codecs/playback filters or add the executables to any blacklists used by the installed codecs/filters.
This may be extreme, but try uninstalling CCCP and see if that makes a difference.
User avatar
ArchDemon
Executive Director
 
Posts: 344
Joined: August 18th, 2006, 7:47 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby anticitizen_one » May 29th, 2012, 5:50 pm

No dice for Act Cadenza.

Although that does seem to have fixed the problem with crashing on vanilla Melty Blood. Is there anything mb.exe should be blacklisted for in CCCP other than ffdshow?

edit: Oddly, I don't have Xvid installed right now either and am using the subtitled OP for vanilla Melty Blood, so shouldn't it not be working at all right now?
anticitizen_one
Totally hardly posted
 
Posts: 4
Joined: May 28th, 2012, 4:04 pm

Re: MB, MBR and MBAC Bug Report Thread

Unread postby ArchDemon » May 29th, 2012, 8:12 pm

anticitizen_one wrote:Although that does seem to have fixed the problem with crashing on vanilla Melty Blood. Is there anything mb.exe should be blacklisted for in CCCP other than ffdshow?

Have you added mb.exe and mbac.exe to all of the blacklists? There should be one for video, one for audio and one for DXVA.
You also might want to disable VSFilter/DirectVobSub if you have that installed too.
Another more extreme thing you could try would be to disable DivX/XviD/MPEG-1 (for non-subbed OP)/MPEG-4 playback in the ffdshow video/DXVA settings and disable MP2 playback in the ffdshow audio settings as a last resort.
I can't think of anything else off the top of my head.

anticitizen_one wrote:edit: Oddly, I don't have Xvid installed right now either and am using the subtitled OP for vanilla Melty Blood, so shouldn't it not be working at all right now?

Windows is probably using a standard MPEG-4 DirectShow filter to playback the video instead.
I encoded the subtitled OP using an older version of Koepi's XviD builds.
You can find his latest build here if you want to give it a try.
User avatar
ArchDemon
Executive Director
 
Posts: 344
Joined: August 18th, 2006, 7:47 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby anticitizen_one » May 29th, 2012, 9:54 pm

Nothing seems to be working, I'm at a loss.

CCCP is definitely the problem with vanilla Melty Blood's video. With that uninstalled, it runs fine. But none of those blacklists or settings or anything seem to be working to let me keep CCCP around.

Act Cadenza's video on the other hand was not working even with CCCP out of the way.

Eh, I think I'm just gonna drop it. The games run fine and the translations are all fine, so it's not really a huge deal. Still pretty irritating though.
anticitizen_one
Totally hardly posted
 
Posts: 4
Joined: May 28th, 2012, 4:04 pm

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » May 30th, 2012, 5:15 am

Perhaps it could be related to the media splitter? Iseem to recall that CCCP offers the option to use Haali for MPEG (in the installer), try disabling that.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Zero3K » October 8th, 2012, 10:55 pm

Is there any way to fix the screen tearing issue that occurs when jumping around?
User avatar
Zero3K
Posting more than n00bs
 
Posts: 21
Joined: April 2nd, 2004, 2:35 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » October 9th, 2012, 6:08 am

What screen tearing issue are you referring to?
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Zero3K » October 11th, 2012, 3:55 am

There's a vertical line/lines that appear when I jump around while fighting.
User avatar
Zero3K
Posting more than n00bs
 
Posts: 21
Joined: April 2nd, 2004, 2:35 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » October 11th, 2012, 5:05 am

You're going to have to supply more details if you want us to help you. We cannot smell the cause of your problems from a distance...
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Zero3K » October 11th, 2012, 5:23 pm

The frames aren't being aligned properly.Here's an example image to show what I mean:

Image
User avatar
Zero3K
Posting more than n00bs
 
Posts: 21
Joined: April 2nd, 2004, 2:35 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » October 12th, 2012, 5:13 am

Yes, we know what screen tearing is.

- What is your OS
- What is your DirectX version
- What is your video card make & model
- What is your video driver version
- What game are you even talking about? o_O
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Zero3K » November 23rd, 2012, 3:28 am

OS: Windows 7
DirectX Version: 11
Video Card: NVIDIA GeForce 9400 GT
Driver Version: 310.61
Game: Melty Blood: Actress Again (Current Code)
User avatar
Zero3K
Posting more than n00bs
 
Posts: 21
Joined: April 2nd, 2004, 2:35 am

Re: MB, MBR and MBAC Bug Report Thread

Unread postby Message » November 23rd, 2012, 5:35 am

Random idea: Have you tried enabling vsync? Have you tried running the game in compat mode?

Other approach: 310.61 are beta drivers, from what I can tell. Have you tried installing the latest stable driver version? 306.81, from the looks of it.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Previous

Return to Melty Blood Chat

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest