Problem Setting Up Server

Talk about WindomXP here!

Moderator: Staffers

Problem Setting Up Server

Unread postby LandMaster » April 4th, 2008, 1:01 am

I've been trying to set up an server to play online with my friends for a week now, and I can't get it right. After reading through the forums on how to set one up correctly, this is what I've managed to sum up to do:

1. Open ports specified in readme.
2. Open Server.exe and make a game.
3. Open game and enter my own IP Address in the box in Online Competition Mode. (BTW, I got mine from one of those websites that tells me my IP)
4. Login then enter room.
5. Give my IP Address to my friends to play.

I can join my room fine, but it seems none of my friends can't. Even one of my other friends set up his own server, after opening the ports and stuff, but I couldn't join his server either.
I know it's not suppose to be this hard to start an online game, so will anyone please tell me what I'm doing wrong.
User avatar
LandMaster
Totally hardly posted
 
Posts: 7
Joined: April 4th, 2008, 12:37 am
Location: The Land

Unread postby WingZero » April 4th, 2008, 1:17 am

Most likely, you're not enabling your ports properly.

When ports are not enabled, one can join his own game but others cannot.

How did you open your ports?
Last edited by WingZero on April 4th, 2008, 8:08 pm, edited 1 time in total.
WingZero
Crack Desu!
 
Posts: 392
Joined: December 21st, 2007, 10:49 pm

Unread postby klonedesu1 » April 4th, 2008, 8:00 pm

I'm having the exact same problem. The only difference is that the computer I'm trying to connect to is on the same LAN.

1.My wireless router has it's firewall/application disabled so there should be nothing interfering.

2. On my computer, I already have ports 2123-2128, 3123-3128 allowed for in/out for the destination and source (I'm using Comodo Firwall Pro).

3. I have the correct local IP address in for my server 192.168.1.xx.

4. I have WindomXP.exe and Server.exe set to be allowed for any tcp/udp in/out.

Each computer can connect to itself when hosting but cannot even see the other computer on the server list.
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Unread postby WingZero » April 4th, 2008, 8:07 pm

I'll say it again: Being able to connect to yourself doesn't really mean anything. I can connect to myself without opening any ports and being on a dynamic IP. Obviously, without ports opened no one else can connect to me. Being able to connect to yourself is indication of nothing. If you're having troubles:

192.168.x.x is the internal dynamic IP which should not be used unless your router is set on DMZ mode with said IP address set as the DMZ host.

I have no idea what you mean by application disabled, but if it is DMZ mode (all ports are open to internet traffic), then get your proper IP address (the DMZ host), instead of your internal dynamic ip.

I cannot in all good conscience recommend turning on DMZ mode if you do not have a good firewall, because you WILL be attacked by random trojans / viruses (If you have a good firewall, then it'll get blocked, and all you'll have is the occasional annoying " has been blocked")

http://whatismyipaddress.com/ is a good site for getting your ACTUAL ip.

IF you are behind a router, you should set up a static IP before enabling ports, and direct all internet traffic to that static IP.

See http://www.portforward.com/networking/staticip.htm for more details.

As for port forwarding, it's simple stuff and varies with each router, but it shouldn't be the actual source of the problem (in any case, double check to see ports are forwarded correctly). If you're behind a firewall, you need to open the ports on BOTH the firewall AND your router. Just one is NOT enough.

It'll most likely work just fine after you get a static IP.
WingZero
Crack Desu!
 
Posts: 392
Joined: December 21st, 2007, 10:49 pm

Unread postby Taz » April 4th, 2008, 9:01 pm

LANDMASTER!

My cousin has this problem, sorta. He can't join ym servers, but other people can. He can make a server, and I can join it, but he can't. It's annoying.
Taz
Totally hardly posted
 
Posts: 7
Joined: March 30th, 2008, 11:32 pm

Unread postby klonedesu1 » April 4th, 2008, 10:11 pm

WingZero wrote:
I have no idea what you mean by application disabled, but if it is DMZ mode (all ports are open to internet traffic)



I mean that the feature on my router to only allow certain applications to pass through it is disabled. So yes, all ports are open to internet traffic on the router.


WingZero wrote:
get your proper IP address (the DMZ host), instead of your internal dynamic ip.



Even when the two computers are on the same LAN? Sorry but I already tried using the public IP and it was worse because I couldn't even connect to myself.


WingZero wrote:
I cannot in all good conscience recommend turning on DMZ mode if you do not have a good firewall, because you WILL be attacked by random trojans / viruses (If you have a good firewall, then it'll get blocked, and all you'll have is the occasional annoying " has been blocked")



No worries, I got all levels covered, firewall, anti-virus and anti-spyware. ;)


WingZero wrote:
IF you are behind a router, you should set up a static IP before enabling ports, and direct all internet traffic to that static IP.
My router is set so that my computers that are connected to it always use the same local IP. So they are static.



My router is set so that my computers that are connected to it always use the same local IP as well. So they are static too :)


WingZero wrote:See http://www.portforward.com/networking/staticip.htm for more details.

As for port forwarding, it's simple stuff and varies with each router, but it shouldn't be the actual source of the problem (in any case, double check to see ports are forwarded correctly). If you're behind a firewall, you need to open the ports on BOTH the firewall AND your router. Just one is NOT enough.


Would port forwarding help me in this situation? I wonder...hmm.... Since I already have the ports open on both the firewall and router, it should be pointless right?
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Unread postby AlinSabel » April 4th, 2008, 10:14 pm

I'm not all that great at tech, but wouldn't people connecting to you actually be connecting to your router? So maybe you'll still have to port forward from the router to your hosting computer.
User avatar
AlinSabel
DESU DESU!
 
Posts: 726
Joined: April 1st, 2008, 10:49 pm

Unread postby WingZero » April 4th, 2008, 11:21 pm

I mean that the feature on my router to only allow certain applications to pass through it is disabled. So yes, all ports are open to internet traffic on the router.


Well, that can be interpreted as "all ports closed". If you're sure it's all ports open, then I guess there's no problem.

I have no idea why you can't connect then. Try port forwarding, and if even that fails, then =/.
WingZero
Crack Desu!
 
Posts: 392
Joined: December 21st, 2007, 10:49 pm

Unread postby klonedesu1 » April 5th, 2008, 12:46 am

WingZero wrote:
I mean that the feature on my router to only allow certain applications to pass through it is disabled. So yes, all ports are open to internet traffic on the router.


Well, that can be interpreted as "all ports closed". If you're sure it's all ports open, then I guess there's no problem.

I have no idea why you can't connect then. Try port forwarding, and if even that fails, then =/.


Yeah I could of been a bit more specific, sorry.

I just found the source of the problem....well, I found the source but not a safe solution. It turns out my firewall software (comodo firewall pro) is responsible for blocking my other computer. I found out when I recklessly decided to shut down my firewall to see if that would do anything when I ran out of ideas lol. I can run a LAN game when the firewall is off, eureka! But the solution is a problem in itself since my computer could become a hacker's playground in a matter of seconds. I went back through to make sure my firewall has the ports open and the programs allowed. They're still on the list. I'm baffled. I know it's the firewall but I don't know why its not working. I tried zonealarm earlier today and it was worse because the free version doesn't let you adjust the ports, only IPs. I'm going to try troubleshooting by going to the comodo website.
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Unread postby klonedesu1 » April 5th, 2008, 6:58 pm

Ugh. Comodo is useless. I'm going to switch my firewall back to zonealarm and go from there lol.
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Re: Problem Setting Up Server

Unread postby klonedesu1 » April 5th, 2008, 7:01 pm

LandMaster wrote:I've been trying to set up an server to play online with my friends for a week now, and I can't get it right. After reading through the forums on how to set one up correctly, this is what I've managed to sum up to do:

1. Open ports specified in readme.
2. Open Server.exe and make a game.
3. Open game and enter my own IP Address in the box in Online Competition Mode. (BTW, I got mine from one of those websites that tells me my IP)
4. Login then enter room.
5. Give my IP Address to my friends to play.

I can join my room fine, but it seems none of my friends can't. Even one of my other friends set up his own server, after opening the ports and stuff, but I couldn't join his server either.
I know it's not suppose to be this hard to start an online game, so will anyone please tell me what I'm doing wrong.


I guess he got it working since he hasn't replied since.
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Unread postby LandMaster » April 5th, 2008, 7:48 pm

Oh sorry, I've been to lazy to check the forums recently. So I just set up a static ip address, and on to the correct way of port forwarding. But I can't open the ports on my router, because I don't seem to know the username and password to be able to change it. Is there anyway around this or somehow find the username and password or do I have to call the manufacturer for that?
User avatar
LandMaster
Totally hardly posted
 
Posts: 7
Joined: April 4th, 2008, 12:37 am
Location: The Land

Unread postby AlinSabel » April 5th, 2008, 10:33 pm

Contact the person in your family that set up the router. If it was you (I highly doubt this), then the default login will be in the documentation that came with the router.
User avatar
AlinSabel
DESU DESU!
 
Posts: 726
Joined: April 1st, 2008, 10:49 pm

Unread postby WingZero » April 5th, 2008, 11:04 pm

IS your router second-hand?

If you bought it new (i.e. from a store), then you should've set a password when the router was first installed (find whoever installed it).

Alternatively, try this:

Depending on your router model, if you chose NOT to set a user/password during router installation, the DEFAULT password can be one of the following:

Username:
Password: admin

(Don't type anything in Username.)

OR

Username: admin
password:

(Don't type anything in password.)
WingZero
Crack Desu!
 
Posts: 392
Joined: December 21st, 2007, 10:49 pm

Unread postby klonedesu1 » April 6th, 2008, 12:50 am

I finally got it working! When I switched to zonealarm and configured everything (the IPs and app permissions) I was able to get my other computer to join my server but for some reason I couldn't join myself. Then I realized that all I needed to do was add myself to the list of acceptable IP and then it worked! I can finally play on the network. Thanks to the peeps who tried to help me :D

WingZero wrote:IS your router second-hand?

If you bought it new (i.e. from a store), then you should've set a password when the router was first installed (find whoever installed it).

Alternatively, try this:

Depending on your router model, if you chose NOT to set a user/password during router installation, the DEFAULT password can be one of the following:

Username:
Password: admin

(Don't type anything in Username.)

OR

Username: admin
password:

(Don't type anything in password.)


What he said. :)
klonedesu1
Addict
 
Posts: 76
Joined: April 4th, 2008, 7:12 pm
Location: Space

Unread postby LandMaster » April 6th, 2008, 9:52 pm

I tried those usernames and password you gave me, but it still doesn't work. I've had this router for quite awhile, but I still remember who installed it. I'll get back to you guys after I contact them.
User avatar
LandMaster
Totally hardly posted
 
Posts: 7
Joined: April 4th, 2008, 12:37 am
Location: The Land

Unread postby md » April 6th, 2008, 10:39 pm

If you have the manual that came with the router, it will tell you in there what the default username and password is. Or you can download it from their website.
User avatar
md
Crack Addic!
 
Posts: 208
Joined: June 18th, 2005, 4:01 am

Unread postby Killingspree » April 7th, 2008, 4:31 pm

Should I connect to my server via my ip adress? Because I've opened ports for my Zonealarm Internet Security and my router, but I still can't find any servers. How can I solve this? :?
Killingspree
Totally hardly posted
 
Posts: 10
Joined: April 1st, 2008, 7:06 pm

Unread postby LandMaster » April 8th, 2008, 3:03 am

After visiting the website of my router, it tells me a simple reset button on my router will return the username and password back to default, bascially allowing me to open my ports, but then it also says all of my router's settings will be erased. Now I'm worried that if I reset my router will cause my internet to malfunction. Now I'm in n argument with myself whether to do it or not.
User avatar
LandMaster
Totally hardly posted
 
Posts: 7
Joined: April 4th, 2008, 12:37 am
Location: The Land

Unread postby Flippy » April 8th, 2008, 5:11 am

Why don't you just use one of the dedicated servers.

I'm one of the people who host a dedicated server that's open 24/7 (Most of the time) to the public. Mainly, this is usually for the people who have a problem with setting up a temporary server to play with friends or need a faster server to connect too.

To join just stick this IP in

twilightx.zapto.org

and connect.

No need to hassle with the port forwarding with the router :D
Flippy
Totally hardly posted
 
Posts: 12
Joined: April 5th, 2008, 3:12 am

Next

Return to WindomXP Chat

Who is online

Users browsing this forum: No registered users and 1 guest