Running Fate/Stay night on 4:3 ratio on a widescreen..

Chat that's general in nature. (Stuff that doesn't belong in any other forum.)

Moderator: Staffers

Running Fate/Stay night on 4:3 ratio on a widescreen..

Unread postby iclim4 » July 5th, 2007, 1:11 am

hello everyone!. i was wondering how you can ^^check title^^
ive seen someone play starcraft and warcraft III in 4:3 ratio on a widescreen laptop and it had black bars at the side..
that would be good for me cuz playing with stretch images kinda makes the game look weird..
my graphics card is Nvidia Geforce go 7600..
any help would be greatly appreciated.. ^^

Edit:
oh and playing in window mode is just too small..
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby Message » July 5th, 2007, 6:37 am

This behaviour isn't controlled by the game itself. You will have to enable this setting either in your LCD panel's setup menu, or in your nVidia drivers.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby Apple » July 5th, 2007, 6:38 am

I play f/sn on my wd laptop and i prefer to stretch it so it fills the screen. tbh i never really noticed anything different (they didnt really look fatter). I actually find that windowed mode looks more weird than wide.
Apple
Posting more than n00bs
 
Posts: 25
Joined: April 13th, 2007, 6:54 pm

Unread postby iclim4 » July 5th, 2007, 7:12 am

Message wrote:This behaviour isn't controlled by the game itself.

i knew that, thats why im in the Tech chat forum instead of the fate/stay forum, and why i have my graphics card posted.

Message wrote:You will have to enable this setting either in your LCD panel's setup menu, or in your nVidia drivers.

umm can you help me with this pls?. ^^,

Apple wrote:I play f/sn on my wd laptop and i prefer to stretch it so it fills the screen. tbh i never really noticed anything different (they didnt really look fatter). I actually find that windowed mode looks more weird than wide.

guess you got used to the wide pictures cause you find the 4:3 ratio weird..
i play on my 17" laptop and i find them considerably fatter.. ='(
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby Message » July 5th, 2007, 7:54 am

Well the problem is that most LCD panels don't have a 'zoom while maintaining aspect ratio' function. So often it's either zoom-and-stretch, or no zoom at all. I've heard that the nVidia drivers have a 'disable zooming' option, and the alternative is to go through your LCD on-screen-display menu and finding a similar option.

Of course laptop LCDs don't have an OSD menu as standalone LCDs have, so in that case you'll have to go to the laptop BIOS and search there.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby iclim4 » July 5th, 2007, 9:05 am

Message wrote:Well the problem is that most LCD panels don't have a 'zoom while maintaining aspect ratio' function. So often it's either zoom-and-stretch, or no zoom at all.

my brother playes starcraft with black bars at the side on his widescreen laptop while starcraft on my laptop is all stretched out.. he doesnt know how he did it though..
i wanted to try installing fate/stay on his laptop for reference but he wont let me ='(
his laptop is 2 years older btw and runs on XP while mine runs on Vista (does OS matter?)
Message wrote:I've heard that the nVidia drivers have a 'disable zooming' option.

TEACH ME!!!... hahaha seriously though i tried that nvidia control panel thing and all it has in the display option is " multiple display"
im lost though so im not even sure thats the right place to go to..
Message wrote:Of course laptop LCDs don't have an OSD menu as standalone LCDs have, so in that case you'll have to go to the laptop BIOS and search there.

well i went there (is that in the start up?. where when you first turn on your computer you press esc?)
it doesnt say anything about the monitor.
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby Eriol-kun » July 5th, 2007, 1:21 pm

Screenshots of the config panel would be of much help. I've done it before too on an XPS, and it's like Message says.
User avatar
Eriol-kun
Crack Addic!
 
Posts: 186
Joined: February 20th, 2007, 5:46 am

Unread postby Message » July 5th, 2007, 1:55 pm

iclim4 wrote:well i went there (is that in the start up?. where when you first turn on your computer you press esc?)
it doesnt say anything about the monitor.

Yes. First Esc, then Del or F2. But chances are that indeed there isn't such an option, some laptop brands have horrible BIOSes (Toshiba, anyone?).
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby iclim4 » July 6th, 2007, 2:41 am

Eriol-kun wrote:Screenshots of the config panel would be of much help. I've done it before too on an XPS, and it's like Message says.

screenshots?......
TADAAA!!!

Image
step one: right click > personalize > display options

Image
clicked advance settings

Image
clicked geforce go 7600 tab

Image
clicked "start the nvidia control panel"

Image
clicked display

so any clues?. i can go in deeper in some parts if you want..

Message wrote:
iclim4 wrote:well i went there (is that in the start up?. where when you first turn on your computer you press esc?)
it doesnt say anything about the monitor.

Yes. First Esc, then Del or F2. But chances are that indeed there isn't such an option, some laptop brands have horrible BIOSes (Toshiba, anyone?).

well there goes one of the alternatives.. guess the nvidia drivers my only hope now..
Last edited by iclim4 on July 6th, 2007, 9:02 am, edited 1 time in total.
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby Message » July 6th, 2007, 7:52 am

I've been looking into this matter for a bit, and it appears that the general term for what we want to do is "1:1 pixel mapping". I've found the nVidia instructions in Dutch, but since I don't have forceware drivers I can't look up the English equivalents. Just look around and see if you can find anything that sounds like what I'm calling it.

In 'cassical' view:
Go to 'Performance and Quality settings'.
Set the Application and Active Profile drowdown menus both to 'With general driver settings'.
Below it, select the 'Display:' dropdown menu to 'Advanced settings'.
In the scrollmenu go all the way down to 'Negative LOD-bias'.
Select this and move the slider to 'clamp'.
Click 'Apply'.
Done!

In the 'new' nVidia control panel (your case, iclim4):
Click '3D-settings'.
Click 'Adjust monitor settings with example'. (???)
Click 'Take me there' (underlined in blue), on the 2nd line below the rotating nVidia logo.
In the scrollmenu at 'General settings', look for 'Negative LOD-bias' and set it to 'clamp'.
Click 'Apply' and you're done.

Now I have no idea if these directions are even close to the truth, but they come from an official post on Gathering of Tweakers which is the 30th largest forum of the world, so they should be relatively well-informed.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby iclim4 » July 6th, 2007, 9:00 am

Message wrote:I've been looking into this matter for a bit, and it appears that the general term for what we want to do is "1:1 pixel mapping". I've found the nVidia instructions in Dutch, but since I don't have forceware drivers I can't look up the English equivalents. Just look around and see if you can find anything that sounds like what I'm calling it.

In 'cassical' view:
Go to 'Performance and Quality settings'.
Set the Application and Active Profile drowdown menus both to 'With general driver settings'.
Below it, select the 'Display:' dropdown menu to 'Advanced settings'.
In the scrollmenu go all the way down to 'Negative LOD-bias'.
Select this and move the slider to 'clamp'.
Click 'Apply'.
Done!

In the 'new' nVidia control panel (your case, iclim4):
Click '3D-settings'.
Click 'Adjust monitor settings with example'. (???)
Click 'Take me there' (underlined in blue), on the 2nd line below the rotating nVidia logo.
In the scrollmenu at 'General settings', look for 'Negative LOD-bias' and set it to 'clamp'.
Click 'Apply' and you're done.

Now I have no idea if these directions are even close to the truth, but they come from an official post on Gathering of Tweakers which is the 30th largest forum of the world, so they should be relatively well-informed.


your instructions are crystal clear, but no it didnt work.. everything is there though from the "take me there,
underlined in blue" to the "Negative LOD-Bias set to clamp" .. but......... ='(
i think my heart stopped beating for a sec when i tryed it cause the instructions seemed so perfect i really expected it to work..
ive also tryd a few things like install different gfx drivers, i think their called forceware ( meant for other nvidia graphics cards), it actually has more options e.g. stuff like digital crispness option(no 4:3 center ratio or 1:1pixel though) but my laptop started acting up (boots really long) so i had no choice but to reinstall my old drivers and update it again..
i also went to the gathering.tweakers.net... how can you even read that?.
lately ive been reading through this

http://www.widescreengamingforum.com/fo ... c.php?t=32

thanks for the effort btw, i really appreciate it.
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby mrthefter » February 19th, 2008, 4:35 am

Far as I know, the way to do it is to goto the nVidia control panel, and then...

1. Set utility to Advanced
2. Expand the Display section
3. Manage custom resolutions
4. Create a new resolution
5. Advanced
6. Bottom, Front-End Parameters, set Scaling Type to Fixed Aspect.

As for the rest of the options, they should already reflect your current settings.

As a quick rundown...
Display (none) is your display's normal zooming, which usually stretches.
Adapter probably does the same thing
Centered means it displays pixel for pixel. 640x480 will run in a small area, surrounded by black bars on ALL sides.
Fixed Aspect will zoom, but maintain the aspect ratio, so as to not cause stretching. This is usually causes black bars to appear on the sides.
mrthefter
Totally hardly posted
 
Posts: 16
Joined: February 18th, 2008, 1:36 am

Unread postby bchan009 » March 10th, 2008, 8:39 pm

This is a pretty easy problem to fix. Just install the latest Nvidia drivers, make sure that the Nvidia control panel is set to show advanced options, and then go to the menu item called "Change Flat panel scaling". Easy as pie. =)

I found a pic on google showing exactly what I'm talking about - if your Nvidia control panel doesn't have this option or has a different layout, make sure you have the latest drivers for your card. :D

And the pic...

Image

No need for custom resolutions or anything. All current Nvidia laptop drivers have this feature. Check out LaptopVideo2Go for drivers if you can't seem to find any - sometimes mobile GPUs aren't supported on Nvidia's actual site. Better yet, check if your laptop manufacturer has released any more recent drivers lately.
bchan009
Posting more than n00bs
 
Posts: 18
Joined: March 10th, 2008, 3:43 am

Unread postby iclim4 » March 10th, 2008, 10:11 pm

bchan009 wrote:This is a pretty easy problem to fix. Just install the latest Nvidia drivers, make sure that the Nvidia control panel is set to show advanced options, and then go to the menu item called "Change Flat panel scaling". Easy as pie. =)

I found a pic on google showing exactly what I'm talking about - if your Nvidia control panel doesn't have this option or has a different layout, make sure you have the latest drivers for your card. :D

And the pic...
No need for custom resolutions or anything. All current Nvidia laptop drivers have this feature. Check out LaptopVideo2Go for drivers if you can't seem to find any - sometimes mobile GPUs aren't supported on Nvidia's actual site. Better yet, check if your laptop manufacturer has released any more recent drivers lately.


Yeah thanks, I got it to work by installing drivers that weren't meant for my laptop from the very same site you recommended, Laptopvideo2go, my laptop didn't have that fixed aspect ratio option before I installed the driver that wasn't meant for my laptop.
It worked for around 6 months, but then my motherboard crapped out....
Lucky I was still in warranty, anyway my laptop was fixed in 1 day since they got it (around 6 days total including when I was waiting for my cardboard coffin)
Hp has awesome customer service, anyway they actually replaced my whole motherboard..

After, I checked Hp's website when I got my PC back to update my drivers, since they restored everything in my HDD, and lou and behold, they just released a Nvidia update driver the just the same month which was Jan 2008. Now I didn't have to use the other driver since the new driver had that option.

Ayway, thanks for your concern.
User avatar
iclim4
Crack Addic!
 
Posts: 173
Joined: June 16th, 2007, 7:51 pm
Location: My Mommy told me not to give out personal information in the internet.

Unread postby bchan009 » March 12th, 2008, 3:10 pm

Glad I could have helped...it's only now that I'm seeing your post was over a year old. wow. I'm a retard. xDD

Oh well.
bchan009
Posting more than n00bs
 
Posts: 18
Joined: March 10th, 2008, 3:43 am


Return to General Chat

Who is online

Users browsing this forum: Bing [Bot] and 2 guests