F/sn Bug Report [v3.1]

It's alright, we feel your pain. Noone wants to admit being gar for Berserker.

Moderator: Staffers

Unread postby Avenger » November 2nd, 2008, 3:13 pm

Message wrote:Have you tried rebooting your machine?

Many times... I also tried to reinstall the game, but that didn't help.
User avatar
Avenger
Totally hardly posted
 
Posts: 13
Joined: August 19th, 2008, 8:42 am
Location: Murmansk, Russia

Unread postby Archaic » November 2nd, 2008, 3:17 pm

Message wrote:To everyone who's posted bug reports so far:

1) Give more details. Your operating system, your windows locale, CD or DVD version, voiced or unvoiced, the circumstances, what you did to make it break, what you did to make it work.

2) Keep posting please, we want to make this game work for everyone. So even if you fixed your problem, we want to know about it.


OS: Windows XP SP3
Media: Fate Stay Night CD version and Realta Nua DVD.
Patch: 3.1

Installation proceeds as normal until the patch asks for the Realta Nua DVD. I've placed the DVD in and installation continues until it stops abruptly and gives me an Error: Invalid File error and installs without voice. Oddly enough this always seems to happen when Patch.xp5 is listed in the white window of the patch.
User avatar
Archaic
Totally hardly posted
 
Posts: 10
Joined: November 2nd, 2008, 4:34 am

Unread postby Balcerzak » November 2nd, 2008, 3:57 pm

System and Installation specs: See above.

The problem: When holding down control to skip past text, in scene Vs Rider "The truth about Sakura" on Day 9, you will skip right past the choices at the end of the scene. (Speculation, it may have something to do with the Status update, though, then again it may not.) This happens both with loaded save files that actually access the text block, and with going through the text block normally. This does not happen with "Scene X already viewed: Skip Y/N".

The problem: Image
One pane scroll-back review: Image

Workaround: Do not use CTRL (or otherly redefined text-skipping) to speed past the text: reading normally, mashing the mouse button, or using autoread do not seem to encounter the problem. Alternately, load up an old save, and use the Skip Entire Scene? dialogues to get you where you need to go.

Note: This also still happens in patch2 for the unvoiced install. (Apparently was never fixed.)

EDIT: I've just confirmed that this problem is not present in the original Japanese by renaming by patch2.xp3 to patch2.xp3.bak. Still investigating what might be the cause, as initial peeking at 桜ルート九日目.fcf and 桜ルート九日目.ks provided no enlightenment.

THEXEV EDIT: Fixed your miss linked image... ^^;
User avatar
Balcerzak
Crack Addic!
 
Posts: 174
Joined: October 29th, 2007, 8:21 pm
Location: Michigan, USA

Unread postby Avenger » November 2nd, 2008, 4:31 pm

I dont know, what i just did, but now v3.1fix is working... :roll: So, my problem is solved :)
User avatar
Avenger
Totally hardly posted
 
Posts: 13
Joined: August 19th, 2008, 8:42 am
Location: Murmansk, Russia

Unread postby Message » November 2nd, 2008, 4:50 pm

Archaic: We still haven't figured out how that happens, except for antivirus software interfering with the huge number of files being processed. Can you confirm that you're not running any protection software that might cause the problem? Also, patch5.xp3 being displayed is normal, that's from before the voiceripping started.

Avenger wrote:I dont know, what i just did, but now v3.1fix is working... :roll: So, my problem is solved :)

Hmmm, maybe I should make it display which file failed deleting, next time...
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby SilentChaos87 » November 2nd, 2008, 5:57 pm

Sorry about how vauge my report was. I've actually managed to fix it myself.

I was using Windows Vista, voiced version, and had installed every patch up to the original 3.1.

When I tried running the fix it wouldn't work. Then I tried running it as an admin and it worked just fine.
User avatar
SilentChaos87
Totally hardly posted
 
Posts: 9
Joined: March 12th, 2008, 8:12 am

Unread postby Message » November 2nd, 2008, 6:18 pm

SilentChaos87 wrote:Sorry about how vauge my report was. I've actually managed to fix it myself.

I was using Windows Vista, voiced version, and had installed every patch up to the original 3.1.

When I tried running the fix it wouldn't work. Then I tried running it as an admin and it worked just fine.

Hmmm, it shouldn't have been a problem... After installing v3.0 or v3.1 the installation directory should've been write-enabled for all users. Can I get back to you on this one some day?
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby SilentChaos87 » November 2nd, 2008, 6:33 pm

Yeah, I can talk with you more on it if you need to.
User avatar
SilentChaos87
Totally hardly posted
 
Posts: 9
Joined: March 12th, 2008, 8:12 am

Re: Heavens Feel Route

Unread postby wiseonekenobi » November 2nd, 2008, 8:43 pm

Taiyou wrote:Hi I've got a problem with the Heavens Feel Route
No matter which choices I made , everytime I choose "Take Sakura home"
it isn't me who takes her home , its always Fuji-nee who takes her home
I made following Choices:
1.)Help Sakura
2.)Go to Work
3.)Take Sakura home

Dunno whats wrong :?: Its always Nee-chan who takes SAkura home..
A Savegame at the spot where SHIROU takes her home would help me ALOT..
Do I have to uninstall v2.0 first before I get the 3.1Patch?


Your problem is more route related, did you happen to clear the UBW route with at lest 1 ending? If so, the flag rinclear=1 should be given and you should have an additional scene where you take sakura home
wiseonekenobi
Totally hardly posted
 
Posts: 5
Joined: November 2nd, 2008, 2:27 am

Unread postby Archaic » November 2nd, 2008, 9:09 pm

Message wrote:Archaic: We still haven't figured out how that happens, except for antivirus software interfering with the huge number of files being processed. Can you confirm that you're not running any protection software that might cause the problem? Also, patch5.xp3 being displayed is normal, that's from before the voiceripping started.

Avenger wrote:I dont know, what i just did, but now v3.1fix is working... :roll: So, my problem is solved :)

Hmmm, maybe I should make it display which file failed deleting, next time...


I got it working so I'll post the workaround. I'm not sure how it happened but this is what I did.

1. Made an image of Realta Nua and mounted it like I read in the FAQ.

2. Turned off my Anti-Virus

3. Ran the patch with Fate in the CD drive and RN mounted.

The Patch and Voice files worked. If this helps anyone I will be glad.
User avatar
Archaic
Totally hardly posted
 
Posts: 10
Joined: November 2nd, 2008, 4:34 am

Unread postby AlinSabel » November 2nd, 2008, 9:36 pm

Didn't you tell me that didn't work? -_-;; (RE: IRC conversation where my advice was 'turn off AV' and 'make an image of the disc')
User avatar
AlinSabel
DESU DESU!
 
Posts: 726
Joined: April 1st, 2008, 10:49 pm

Unread postby Neo2x » November 2nd, 2008, 10:19 pm

Same error as Balcerzak, when accessing "15th Day: Return home, night "Before the final battle"" via normal playthrough (the image freezes, but can still access the menu) or a save game (game goes to the initial menu). In both cases I receive an information box before it happening.

ImageImage

OS: Spanish Windows XP SP2
Game Version: 3CD Version with 3.1 patch, fix and voices from Realta Nua DVD.
Clean installation, didn't use other patches.
Neo2x
Totally hardly posted
 
Posts: 8
Joined: July 27th, 2006, 10:36 pm

Unread postby wiseonekenobi » November 2nd, 2008, 10:23 pm

Neo2x wrote:Same error as Balcerzak, when accessing "15th Day: Return home, night "Before the final battle"" via normal playthrough (the image freezes, but can still access the menu) or a save game (game goes to the initial menu). In both cases I receive an information box before it happening.

ImageImage

OS: Spanish Windows XP SP2
Game Version: 3CD Version with 3.1 patch, fix and voices from Realta Nua DVD.
Clean installation, didn't use other patches.


robthemanbigboy suggested earlier to try and install the V2.0 patch (UBWrelease), i will try this tomorrow and post the results. Meanwhile Neo2x, you could give it a try to and tell us if it solves the problem
wiseonekenobi
Totally hardly posted
 
Posts: 5
Joined: November 2nd, 2008, 2:27 am

Unread postby Archaic » November 2nd, 2008, 10:32 pm

AlinSabel wrote:Didn't you tell me that didn't work? -_-;; (RE: IRC conversation where my advice was 'turn off AV' and 'make an image of the disc')


It worked this time. I had done that before and had no success. I have no idea what made it go differently this time AlinSabel. Nevertheless I thank you for all your help as your advice worked, just not on the first try.
User avatar
Archaic
Totally hardly posted
 
Posts: 10
Joined: November 2nd, 2008, 4:34 am

Unread postby Neo2x » November 2nd, 2008, 11:42 pm

wiseonekenobi wrote:
Neo2x wrote:Same error as Balcerzak, when accessing "15th Day: Return home, night "Before the final battle"" via normal playthrough (the image freezes, but can still access the menu) or a save game (game goes to the initial menu). In both cases I receive an information box before it happening.

ImageImage

OS: Spanish Windows XP SP2
Game Version: 3CD Version with 3.1 patch, fix and voices from Realta Nua DVD.
Clean installation, didn't use other patches.


robthemanbigboy suggested earlier to try and install the V2.0 patch (UBWrelease), i will try this tomorrow and post the results. Meanwhile Neo2x, you could give it a try to and tell us if it solves the problem


Yeah, but he also said that way some problems with saved games presented, and people may not want to that to happen. Also Balcerzak workaround works (renaming the voice file), but that isn't a permanent solution.
Neo2x
Totally hardly posted
 
Posts: 8
Joined: July 27th, 2006, 10:36 pm

Unread postby AnonymousV2 » November 3rd, 2008, 12:49 am

Balcerzak wrote:System and Installation specs: See above.

The problem: When holding down control to skip past text, in scene Vs Rider "The truth about Sakura" on Day 9, you will skip right past the choices at the end of the scene. (Speculation, it may have something to do with the Status update, though, then again it may not.) This happens both with loaded save files that actually access the text block, and with going through the text block normally. This does not happen with "Scene X already viewed: Skip Y/N".

The problem: Image
One pane scroll-back review: Image

Workaround: Do not use CTRL (or otherly redefined text-skipping) to speed past the text: reading normally, mashing the mouse button, or using autoread do not seem to encounter the problem. Alternately, load up an old save, and use the Skip Entire Scene? dialogues to get you where you need to go.

Note: This also still happens in patch2 for the unvoiced install. (Apparently was never fixed.)

EDIT: I've just confirmed that this problem is not present in the original Japanese by renaming by patch2.xp3 to patch2.xp3.bak. Still investigating what might be the cause, as initial peeking at 桜ルート九日目.fcf and 桜ルート九日目.ks provided no enlightenment.


I get the exact same problem with Nurse Sakura - A simple question on day 6. To add to your workaround, saving the game at the blank screen, loading up that save and reading normally up to the choices will load them correctly and is the fastest way to get past it.
AnonymousV2
Totally hardly posted
 
Posts: 9
Joined: December 14th, 2007, 3:01 am

Unread postby sushimonster » November 3rd, 2008, 2:35 am

Intel Celeron M (1.6GHz)
128MB Graphics RAM (ATI RADEON EXPRESS 200M)
640MB system RAM
Windows XP SP3 (Korean version)
Fate stay night DVD used (installed using V2.0)
Realta Nua voice patch installed (installed using V2.0)
Overwrote v2.0 with v3.1 and with fix

It seems that the v3.1 doesn't play some of the saves that were made with v2.0. A error message sometimes comes up in Japanese, saying something about the screenshot the save file had. This is quite common with the UBW.
Also, the program doesn't seem to be as stable in my case - gets laggy sometimes when switching from main menu to load menu, or from game to main menu... Still trying to determine whether any of my Fate saves are affected.

Other than that, all sweet - good work mirrormoon~!
User avatar
sushimonster
Crack Addic!
 
Posts: 123
Joined: October 1st, 2008, 10:25 am
Location: Aotearoa - JafaTown

Unread postby DevilKingBaal » November 3rd, 2008, 7:30 am

Image

Help would be highly appreciated.
User avatar
DevilKingBaal
Posting more than n00bs
 
Posts: 20
Joined: November 3rd, 2008, 7:23 am

Unread postby Message » November 3rd, 2008, 7:37 am

DevilKingBaal wrote:Help would be highly appreciated.

We're working on it. A workaround has been posted above by whatshisname.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby DevilKingBaal » November 3rd, 2008, 7:45 am

Nevermind I looked into some of the earlier posts and did what robtheman did. It's working now.
User avatar
DevilKingBaal
Posting more than n00bs
 
Posts: 20
Joined: November 3rd, 2008, 7:23 am

PreviousNext

Return to Fate/stay night Chat

Who is online

Users browsing this forum: No registered users and 2 guests