[Solved][Linux] Help in Tsukihime English Installation

Caution: Flying pans at low altitude.

Moderator: Staffers

[Solved][Linux] Help in Tsukihime English Installation

Unread postby darckense » March 7th, 2007, 10:10 am

Hello !

I've recently seen that Mirrormoon has finished the translation of Tsukihime. Thank you very much for the work !! My level in Japanese is not good enought to play the game, so now, I can enjoy it.
It's working perfectly under Win XP, but I would like to have it working under Linux, so I tried to compile onscripter, according to the guideline found on Mirrormoon website.

My system is Mandriva 2007 Official, with a 2.6.17 kernel (2.6.17-5mdv).
I *think* that I've installed all the dependencies for SDL (but maybe I'm wrong on this point, I'm not very used to compile program).
I applied the mirrormoon patch to 20060724 version of onscripter source code.
However, I failed to compile properly onscripter.

I know that mirrormoon does'nt provide support for onscripter compilation, but I wonder if a Linux user who has already solved this problem may help me.

It's look like I cannot put the output of compilation on this forum, but I reproduced the error message I get.

Thank you in advance for any help you could give me, and I wish good luck for all the guy currently working on the Fate/Stay Night translation (Ganbatte !!).

Code: Select all
Error message :

/usr/bin/ld: cannot find -lpthread
collect2: ld returned 1 exit status
make: *** [onscripter] Erreur 1
Last edited by darckense on March 9th, 2007, 1:35 pm, edited 3 times in total.
User avatar
darckense
Into 17 Pieces
 
Posts: 17
Joined: March 7th, 2007, 9:09 am
Location: Tokyo

Unread postby puKKa » March 7th, 2007, 2:22 pm

I'm not very into linux since I'm such a lazy person but it could be that you are missing some dependant library or such.
You could probably get more help at insanis site about ONS I believe. You could probably do some go-around by installing it on win and then usign the files in linux. Just an idea.

Godd luck ^^
iddqd
User avatar
puKKa
I kick on girls trying to kill me
 
Posts: 537
Joined: November 29th, 2006, 6:57 pm
Location: Sweden

Unread postby Message » March 7th, 2007, 3:12 pm

puKKa: You cannot use insani's ONS builds with the resource files from Tsukihime English. We modified ONScripter to support both arc.nsa and arc.sar at the same time, using an already existing build with Tsukihime English will result in a crash at the main menu.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby darckense » March 7th, 2007, 4:11 pm

I went to everything again, and I think that I've all the dependencies.
However, I did'nt edit the makefile, which could be the problem here. But, the point is that I don't know how to edit such a file... Every time I had to compile a program from sources, there was a .configure script to build the makefile... :-/

Below is the makefile I used :

Code: Select all
# -*- Makefile -*-
#
# Makefile.Linux - Makefile rules for linux
#

# without OggVorbis and AVI
#INCS = `sdl-config --cflags` `smpeg-config --cflags`
#LIBS = `sdl-config --libs` `smpeg-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm
#DEFS = -DLINUX


INCS = `sdl-config --cflags` `smpeg-config --cflags`
#INCS = `sdl-config --cflags` `smpeg-config --cflags` `avifile-config --cflags`

# with OggVorbis and AVI
#LIBS = `sdl-config --libs` `smpeg-config --libs` `avifile-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm -lvorbis
#DEFS = -DLINUX -DUSE_AVIFILE -DUSE_OGG_VORBIS

# with Integer OggVorbis and AVI in PDA size
#LIBS = `sdl-config --libs` `smpeg-config --libs` `avifile-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm -lvorbisidec
#DEFS = -DLINUX -DUSE_AVIFILE -DUSE_OGG_VORBIS -DINTEGER_OGG_VORBIS -DPDA -DPDA_VGA

# with OggVorbis and AVI and English mode
#LIBS = `sdl-config --libs` `smpeg-config --libs` `avifile-config --libs` -lSDL_ttf -lSDL_image -lSDL_mixer -lbz2 -ljpeg -lm -lvorbis
#DEFS = -DLINUX -DUSE_AVIFILE -DUSE_OGG_VORBIS -DENABLE_1BYTE_CHAR -DFORCE_1BYTE_CHAR

# with OggVorbis and English mode and insani
LIBS = -static -z muldefs -Wl,--start-group `sdl-config --static-libs` `smpeg-config --libs` -lSDL_ttf -lfreetype -lSDL_image -ltiff -lpng -lSDL_mixer -lbz2 -lz -ljpeg -lm -lvorbis -lvorbisenc -lvorbisfile -logg -lgpm -lncurses -lslang -ldirectfb -lfusion -ldirect -lvga -ldl -lesd -lartsc -lasound -lX11 -laa -Wl,--end-group
DEFS = -DLINUX -DUSE_OGG_VORBIS -DENABLE_1BYTE_CHAR -DFORCE_1BYTE_CHAR -DINSANI

EXESUFFIX =
OBJSUFFIX = .o

.SUFFIXES:
.SUFFIXES: $(OBJSUFFIX) .cpp .h

# for GNU g++
CC = g++
LD = g++ -o

#CFLAGS = -g -Wall -Wpointer-arith -pipe -c $(INCS) $(DEFS)
CFLAGS = -O3 -Wall -fomit-frame-pointer -pipe -c $(INCS) $(DEFS)

# for GCC on PowerPC specfied
#CC = powerpc-unknown-linux-gnu-g++
#LD = powerpc-unknown-linux-gnu-g++ -o

#CFLAGS = -O3 -mtune=G4 -maltivec -mabi=altivec -mpowerpc-gfxopt -mmultiple -mstring -Wall -fomit-frame-pointer -pipe -c $(INCS) $(DEFS)

# for Intel compiler
#CC = icc
#LD = icc -o

#CFLAGS = -O3 -tpp6 -xK -c $(INCS) $(DEFS)

RM = rm -f

TARGET = onscripter$(EXESUFFIX) sardec$(EXESUFFIX) nsadec$(EXESUFFIX) sarconv$(EXESUFFIX) nsaconv$(EXESUFFIX)
#TARGET = onscripter$(EXESUFFIX) sardec$(EXESUFFIX) nsadec$(EXESUFFIX) sarconv$(EXESUFFIX) nsaconv$(EXESUFFIX) simple_aviplay$(EXESUFFIX)
#EXT_OBJS = AVIWrapper$(OBJSUFFIX)

include Makefile.onscripter


Thank you for your help ! :-D
User avatar
darckense
Into 17 Pieces
 
Posts: 17
Joined: March 7th, 2007, 9:09 am
Location: Tokyo

Compilation

Unread postby darckense » March 9th, 2007, 11:30 am

Ok, I've asked a Linux guru in my lab, and he solved my problem.

I missed two library (mandriva 2007):
1/ libtiff3-devel
2/ libsvgalib1-devel

The makefile was modified to remove the -static option :
Here is the diff output of the makefile I used :

Code: Select all
28c28,29
< LIBS = -static -z muldefs -Wl,--start-group `sdl-config --static-libs` `smpeg-config --libs` -lSDL_ttf -lfreetype -lSDL_image -ltiff -lpng -lSDL_mixer -lbz2 -lz -ljpeg -lm -lvorbis -lvorbisenc -lvorbisfile -logg -lgpm -lncurses -lslang -ldirectfb -lfusion -ldirect -lvga -ldl -lesd -lartsc -lasound -lX11 -laa -Wl,--end-group
---
> # LIBS = -static -z muldefs -Wl,--start-group `sdl-config --static-libs` `smpeg-config --libs` -lSDL_ttf -lfreetype -lSDL_image -ltiff -lpng -lSDL_mixer -lbz2 -lz -ljpeg -lm -lvorbis -lvorbisenc -lvorbisfile -logg -lgpm -lncurses -lslang -ldirectfb -lfusion -ldirect -lvga -ldl -lesd -lartsc -lasound -lX11 -laa -Wl,--end-group
> LIBS = -z muldefs -Wl,--start-group `sdl-config --libs` `smpeg-config --libs` -lSDL_ttf -lfreetype -lSDL_image -ltiff -lpng -lSDL_mixer -lbz2 -lz -ljpeg -lm -lvorbis -lvorbisenc -lvorbisfile -logg -lgpm -lncurses -lslang -ldirectfb -lfusion -ldirect -lvga -ldl -lesd -lartsc -lasound -lX11 -laa -Wl,--end-group



I copied default.ttf, nscript.dat, arc.sar and arc.nsa to my onscripter directory, and the game started !! :-D

However, there is a bug. I could see the introduction, but the program cause a segfault when I arrived to the main title.
Here is the output :

Code: Select all
[darckense@ tsukihime]$ ./onscripter
ONScripter version 20060724-insani(2.55)
Autodetect: insanity spirit detected!
Display: 640 x 480 (32 bpp)
Audio: 44100 Hz 16 bit stereo
 *** can't find file [cursor0.bmp] ***
 *** can't find file [cursor1.bmp] ***
 *** can't find file [image\word\mirrormoon.png] ***
 *** can't find file [icon\0.bmp] ***
 *** can't find file [icon\0.bmp] ***
 *** can't find file [image\title\title1.png] ***
 *** can't find file [image\title\titlebtn1.png] ***
Erreur de segmentation
[darckense@ tsukihime]$         
User avatar
darckense
Into 17 Pieces
 
Posts: 17
Joined: March 7th, 2007, 9:09 am
Location: Tokyo

Unread postby c15zyx » March 9th, 2007, 11:55 am

Something like that comes up if you didn't use (or didn't correctly use) Mirror Moon's patch.
c15zyx
Totally hardly posted
 
Posts: 15
Joined: February 20th, 2007, 5:58 am

Unread postby darckense » March 9th, 2007, 1:34 pm

c15zyx wrote:Something like that comes up if you didn't use (or didn't correctly use) Mirror Moon's patch.


:-D
It works perfectly now. I didn't use the patch correctly the first time...

However, I still need to remove the -static option from the compilation line to compile properly.


Thanks you all for your help. I can now enjoy this wonderful game under my favorite OS.
User avatar
darckense
Into 17 Pieces
 
Posts: 17
Joined: March 7th, 2007, 9:09 am
Location: Tokyo

Unread postby c15zyx » March 9th, 2007, 2:51 pm

darckense wrote:However, I still need to remove the -static option from the compilation line to compile properly.


Yeah, the Makefiles are kinda messy. For the Mac OS X Makefile, several necessary libraries were omitted, and some unnecessary ones were included as well (libvorbisenc, etc). Also, though the Makefile defaults to linking to static libs when possible, it mistakenly uses g++ (forces dynamic links to gcc libs) instead of gcc combined with static stdc++ and gcc_eh which would allow the binary to work on other computers.
c15zyx
Totally hardly posted
 
Posts: 15
Joined: February 20th, 2007, 5:58 am


Return to Tsukihime Chat

Who is online

Users browsing this forum: No registered users and 2 guests