Tsukihime English bug reports (Read first post!) [v1.0]

Caution: Flying pans at low altitude.

Moderator: Staffers

Unread postby Danj » November 7th, 2006, 11:54 am

OS: Windows XP SP2
System locale: English
AppLocale: not in use
Tsukihime version: TsukiBako
Tsukihime English version: 1.0
CPU: AMD Athlon XP 3000+ (socket A)
Memory: 1Gb
Motherboard: Asrock K7VT4A Pro (VIA KT400A chipset)
Video card: nVidia Geforce 6600 256Mb AGP
Video driver version: 91.47
Music ripped with: CDex 1.70 beta 2 (UNICODE) with LAME 3.97 beta 2 MMX
Bug type: reproducible - status: resolved
stderr.txt contents:
Autodetect: insanity spirit detected!
*** plugin jpgplgin.dll|jpg is not available, ignored. ***
command [cdfadeout] is not supported yet!!
*** can't find file [cursor0.bmp] ***
*** can't find file [cursor1.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
can't open save file sav\save1.dat for writing (not an error)
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
can't open save file sav\save1.dat for writing (not an error)

stdout.txt is blank

Report:
When beginning the first chapter (Impulse Inversion I), the game displays the first few lines on a black background, then changes to a blue sky bitmap background and hangs.

Things I tried:
  • I tried taking the CD out of the drive in case it was a CD-DA issue but this did not affect the problem.
  • I tried deleting the mp3s from the CD folder, this allowed the game to proceed.


EDIT:
Workaround:
Deleting the mp3s from the CD folder allowed the game to proceed past the point mentioned.

Resolution:
Encoded the music to ogg instead of mp3.


Conclusion:
MP3 support is variable in its reliability due to the multiplicity of encoders and decoders out there, but the vast majority of OGG-supporting applications use libvorbis or similar and can therefore be relied upon to provide a more uniform user experience.

Summary:
If you have crash problems which are resolved by deleting the mp3s, but you still want music, try encoding to ogg instead.
Last edited by Danj on November 7th, 2006, 12:33 pm, edited 2 times in total.
Dan Jackson
User avatar
Danj
Might just like this board
 
Posts: 49
Joined: November 7th, 2006, 11:30 am
Location: Cambridge, UK

Unread postby Misuzu » November 7th, 2006, 12:09 pm

Hrmm... I seem to running into a small oddity in Ciels path.

Like three times around that massive Ciel multi-variable checkpoint (the s261-s266 block), the game would display a line of text and just kinda hang there for like 30 or 40 secs even though I would hit enter. Then it would suddenly blaze a couples lines really fast. I think this occured while I was on block s261 before it jumped to the next block, but I'm not sure since there is no break between those blocks.

My stderr.txt is below:
Autodetect: insanity spirit detected!
*** plugin jpgplgin.dll|jpg is not available, ignored. ***
command [cdfadeout] is not supported yet!!
*** can't find file [cursor0.bmp] ***
*** can't find file [cursor1.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
readToken: skip unknown heading character + (2b)
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
User avatar
Misuzu
Totally hardly posted
 
Posts: 4
Joined: October 4th, 2005, 6:18 am

Unread postby Hyperbeast » November 7th, 2006, 2:19 pm

Message wrote:
Hyperbeast wrote:Oh, something maybe to check, for those of you who can't get the music working, are you running the non-ero version? That could be why.

I don't know where you got this idea, but I have seen nothing that points in this direction. If you can show that non-ero has anything to do with music problems, please do so.


Uh... I have nothing to support that, but I'm running the normal version, so I thought that maybe it could just be some problem in the non-ero version causing it. Well... Scratch that theory then.
Still not noticed any bugs myself. Lucky me.
User avatar
Hyperbeast
Crack Addic!
 
Posts: 157
Joined: January 9th, 2006, 11:29 pm
Location: The arse end of the world, Australia.

Unread postby riffwraith » November 7th, 2006, 2:46 pm

I haven't had any real issues (crashes), but upon beating Akiha's Normal Ending and checking the endings list I noticed that it had not updated with her ending. I duplicated this error and noticed that every time I beat her ending, stderr.txt added
*** can't find file [image\word\ed_17.png] ***

I can only assume that it tries to add the image containing the text, and then fails for some reason.

I'm using standard version 1.0 of tsukihime, on a winxp home box.
riffwraith
Totally hardly posted
 
Posts: 1
Joined: November 7th, 2006, 2:41 pm

Unread postby Message » November 8th, 2006, 4:33 pm

riffwraith wrote:I haven't had any real issues (crashes), but upon beating Akiha's Normal Ending and checking the endings list I noticed that it had not updated with her ending. I duplicated this error and noticed that every time I beat her ending, stderr.txt added
*** can't find file [image\word\ed_17.png] ***

I can only assume that it tries to add the image containing the text, and then fails for some reason.

I'm using standard version 1.0 of tsukihime, on a winxp home box.

The ed_17.png error is caused by a bug in the end credits, we will fix that in the next version. Thanks for reporting it. As for the AKiha Normal Ending not registering, this is a peculiarity of the original game. If you choose to chase Akiha instead of letting go, you can progress to the REAL Akiha Normal Ending. The one you got is a copy of the real ending, but doesn't count as an ending even though Ciel-sensei says it is. If you look in the flowchart, the ending you got is s509 while the real Akiha Normal Ending is s384.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby Message » November 8th, 2006, 4:39 pm

To all people having problems with ONScripter freezing at random locations: Danj suggested using ogg instead of mp3 for the music, and so far it appears to be working. For this, you must remove the mp3 files from the CD directory and replace them with track01.ogg, track02.ogg, ..., track10.ogg. I cannot guarantee that this will solve your problems, but since it seems to work in many cases I suggest giving it a try. Please let us know whether or not it works for you.

Several OGG encoders are listed on the Vorbis website.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby Henduluin » November 8th, 2006, 5:27 pm

Yeah, I tried that earlier today after having crashed several times in a row, and I've been playing several hours non-stop since.
User avatar
Henduluin
Crack Desu!
 
Posts: 341
Joined: November 5th, 2006, 3:29 pm
Location: Dutchtopia

Unread postby MetalGravy » November 9th, 2006, 1:56 am

TheXev wrote:NOTE- Please install Tsukihime into a separate folder, and not over a current installation. This may be the cause of some problems in relation to our patch!

NOTE- Please read the readme.txt file included with the Tsukihime patch.


How will the patch know where Tsukihime is located? Do we have to tell it where Tsukihime is installed, or should the patch be installed in a directory at the root level of the Tsukihime directory?
MetalGravy
Totally hardly posted
 
Posts: 8
Joined: April 29th, 2006, 2:05 am

Unread postby md » November 9th, 2006, 2:41 am

MetalGravy wrote:
TheXev wrote:NOTE- Please install Tsukihime into a separate folder, and not over a current installation. This may be the cause of some problems in relation to our patch!

NOTE- Please read the readme.txt file included with the Tsukihime patch.


How will the patch know where Tsukihime is located? Do we have to tell it where Tsukihime is installed, or should the patch be installed in a directory at the root level of the Tsukihime directory?


The patch asks for the data file from the tsukihime CD and patches it directly while copying it over to your harddrive. That's why it needs a new clean install. It's its own version of the game.
User avatar
md
Crack Addic!
 
Posts: 208
Joined: June 18th, 2005, 4:01 am

Unread postby MetalGravy » November 9th, 2006, 4:03 am

Yeah, I see. I installed it right after asking. Guess I should've waited before posting.

On a slightly more humorous note, turns out that InstallShield can't read kanji.
MetalGravy
Totally hardly posted
 
Posts: 8
Joined: April 29th, 2006, 2:05 am

Unread postby Prime234 » November 9th, 2006, 5:53 am

OK I finally resolved my audio issues. It was mostly luck, thanks for the help guys and thanks for releasing this patch!
User avatar
Prime234
Totally hardly posted
 
Posts: 5
Joined: November 5th, 2006, 6:26 pm
Location: Toledo,OH

Can't get pass Main Menu

Unread postby DestinFaroda » November 9th, 2006, 1:48 pm

In the beginning I had no background just text but I WAS able to bypass the main menu and continue on with the story.

But without background images.

I was able to fix my problem by copying the arc.nsa from the CD and copying it into the english version's folder, I was able to view the opening in english with background images, but now it crashes at main menu, how can I fix this?

Edit: this is not caused by music, I removed the CD folder and it still crashed at Main Menu.
DestinFaroda
Totally hardly posted
 
Posts: 1
Joined: November 9th, 2006, 1:45 pm

Unread postby MetalGravy » November 10th, 2006, 2:19 am

What file are we supposed to rip the music from? I d/l-ed oggdropXPd to rip the music, but when I put the cd in, the only option for ripping that I get is using WMP.

I am getting sound effects (such as the clock in the hospital room and the school bell) from the CD, though. Is that normal?
MetalGravy
Totally hardly posted
 
Posts: 8
Joined: April 29th, 2006, 2:05 am

Re: Can't get pass Main Menu

Unread postby Message » November 10th, 2006, 8:58 am

DestinFaroda wrote:I was able to fix my problem by copying the arc.nsa from the CD and copying it into the english version's folder, I was able to view the opening in english with background images, but now it crashes at main menu, how can I fix this?

If there is a file called arc.nsa on your CD, you do not have a copy of Tsukihime. Most probably it is a CD of Kagetsu Tohya, the sequel to Tsukihime. Yesterday in the IRC channel I told whatshisname that it was possible to use KT for Tsukihime, but I just found out I was wrong. Sorry, I'm afraid you're out of luck.

MetalGravy wrote:What file are we supposed to rip the music from? I d/l-ed oggdropXPd to rip the music, but when I put the cd in, the only option for ripping that I get is using WMP.

Rip FROM..? I haven't used those ogg encoders (my mp3s work fine), but I imagine you'd first have to rip the CD to .wav files using EAC, then you can open those in oggdrop and encode to .ogg.

MetalGravy wrote:I am getting sound effects (such as the clock in the hospital room and the school bell) from the CD, though. Is that normal?

No, getting sound effects from the CD is NOT normal. The CD should only have the game's datafiles and cd-da music. >_> If you mean that soundeffects work in the game, then yes that is normal. After installation of Tsukihime English you don't need the CD in the drive to play.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

Unread postby GFBeachy » November 11th, 2006, 7:27 am

I cleared the game today with Arcueid's true ending and just after the 'Fin' screen when the credits started, the game crashed. When I re-load the game, the endings screen within the Options menu doesn't show anything cleared.

A quick look at the PDF flowchart shows that this locks me out of several other options during replays, so I'd like to find a way around this... If the reason for the crash can't be solved, is there a way to edit the game data to turn on the completion flag for this story arc?

OS: Windows XP SP2
JP Game version: Unknown
Translation patch version: 1.0
CPU/RAM/Motherboard: Athlon 64 3000/1gb/MSI K8N Neo4
Video Drivers: Nvidia 71.84
stderr contents: Autodetect: insanity spirit detected!
*** plugin jpgplgin.dll|jpg is not available, ignored. ***
command [cdfadeout] is not supported yet!!
*** can't find file [cursor0.bmp] ***
*** can't find file [cursor1.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [icon\0.bmp] ***
*** can't find file [image\word\ed_17.png] ***
GFBeachy
Totally hardly posted
 
Posts: 7
Joined: November 11th, 2006, 7:23 am

Unread postby GFBeachy » November 11th, 2006, 3:02 pm

I figured I'd give removing the MP3 music a try and see if it fixes the crashing bug. Lo and behold, it does! The game doesn't crash and now registers the completed ending. Hooray.
GFBeachy
Totally hardly posted
 
Posts: 7
Joined: November 11th, 2006, 7:23 am

Unread postby Message » November 11th, 2006, 5:32 pm

Thanks for your report, GFBeachy. We will probably switch over to ogg music for the next version, this should prevent these problems.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

images not working for some reason

Unread postby swordmaster » November 12th, 2006, 8:47 pm

maybe this was already answer but my images won't appear during the game.
When I started it up I got the stderr file and all it says is:

Autodetect: insanity spirit detected!
*** plugin jpgplgin.dll|jpg is not available, ignored. ***
command [cdfadeout] is not supported yet!!
*** can't find file [icon\uoncur.bmp] ***
*** can't find file [icon\uoffcur.bmp] ***
*** can't find file [icon\doncur.bmp] ***
*** can't find file [icon\doffcur.bmp] ***
*** can't find file [uoncur.bmp] ***
*** can't find file [uoffcur.bmp] ***
*** can't find file [doncur.bmp] ***
*** can't find file [doffcur.bmp] ***
*** can't find file [cursor0.bmp] ***
*** can't find file [cursor1.bmp] ***
*** can't find file [icon\cursor0.bmp] ***
*** can't find file [icon\cursor1.bmp] ***
*** can't find file [image\word\type_moon.jpg] ***
*** can't find file [image\bg\ima_10.jpg] ***
*** can't find file [image\gameopt\effectok.jpg] ***
etc.....

i have no clue on how to fix this problem or maybe i installed it wrong...somehow.
Any ideas will be greatly appreciated

ps- i put the arc.sar file in a folder then used the translator..installedi t and that bunch of things came up.
swordmaster
Totally hardly posted
 
Posts: 3
Joined: November 12th, 2006, 8:36 pm

Re: images not working for some reason

Unread postby Message » November 12th, 2006, 8:58 pm

swordmaster wrote:ps- i put the arc.sar file in a folder then used the translator..installedi t and that bunch of things came up.

I hope you can understand that that does not equal a short, clear description of the problem... I suggest you run the installer again, and follow the instructions onscreen. If you still have problems, please post a reply here and give us all the information we asked for in the first post of this thread.
User avatar
Message
Master of Bad Puns
 
Posts: 1845
Joined: October 25th, 2004, 6:27 pm
Location: Netherlands

heres a full description of what you wanted

Unread postby swordmaster » November 12th, 2006, 11:04 pm

Problem: Tsukihime does not show any backround or during game images
OS: Windows XP SP2 with a ATI Radion x300 Se and 512 mb RAM
Tsukihime VER: 0.1 Stardard Edition.

When I used the translator I created it in a different file as said in the first post. Everything works fine except there are no images during any part of the game except for the beginning menu.

Also when i started the game up a stderr.txt file appeared and said:

Autodetect: insanity spirit detected!
*** plugin jpgplgin.dll|jpg is not available, ignored. ***
command [cdfadeout] is not supported yet!!
*** can't find file [icon\uoncur.bmp] ***
*** can't find file [icon\uoffcur.bmp] ***
*** can't find file [icon\doncur.bmp] ***
*** can't find file [icon\doffcur.bmp] ***
*** can't find file [uoncur.bmp] ***
*** can't find file [uoffcur.bmp] ***
*** can't find file [doncur.bmp] ***
*** can't find file [doffcur.bmp] ***
*** can't find file [cursor0.bmp] ***
*** can't find file [cursor1.bmp] ***
*** can't find file [icon\cursor0.bmp] ***
*** can't find file [icon\cursor1.bmp] ***
*** can't find file [image\word\type_moon.jpg] ***
*** can't find file [image\bg\ima_10.jpg] ***
*** can't find file [image\gameopt\effectok.jpg] ***
etc.....

Its mostly just saying the images aren't coming up.
So yea you get the picture
If i did somethign wrong let me know.
swordmaster
Totally hardly posted
 
Posts: 3
Joined: November 12th, 2006, 8:36 pm

PreviousNext

Return to Tsukihime Chat

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron